Search

K12USA Support Knowledge Base

Cisco Switch VLAN Setup (IOS)

WirelessTrakker

Summary

WirelessTrakker requires that the switch ports involved for connecting the components for WirelessTrakker be 802.1q VLAN tagged / trunked ports.  These directions tell you how to do that.  Note: These were written using a Cisco Catalyst 2950.  While this should work for most modern Cisco switches running IOS (as opposed to the older CatOS), some Cisco equipment has small nuances that may be different.

Applies To

WirelessTrakker, Cisco switches

More Information

Before configuring any switch ports, you need to first identify which ports will be involved.  All ports that are involved need to be worked on.  This includes intermediary ports between the WirelessTrakker Access Points and the WirelessTrakker Controller.  For example, consider the following network setup:



Using VLAN 100 for the WirelessTrakker management VLAN, and VLANs 101, 102, 103 and 104 for four different SSIDs, the following ports need the following configurations (this assumes there are no other VLANs on your network):

Switch Port Native VLAN  Tagged VLANs 
1 0/1 1 100,101,102,103,104
1 0/2  100 101,102,103,104
2 0/1 1 100,101,102,103,104
2 0/2 1 100,101,102,103,104
3 0/1 1 100,101,102,103,104
3 0/23 100 101,102,103,104
3 0/24 100 101,102,103,104

The ports the WirelessTrakker devices are connected to need to have their native / untagged VLAN ID set to the management VLAN (100 in this case), and allow VLANs 101, 102, 103 and 104.  The VLAN information needs to make it through the network from the access points back to the controller.  Therefore, all the ports in between need to allow the VLAN tagged frames through, while continuing to pass the default traffic (VLAN 1) without touching it.  To configure Switch 1, you would need to run these commands at the console:


enable
config t

vlan 100
name Management
state active
no shutdown
exit

vlan 101
name Student
state active
no shutdown
exit

vlan 102
name Staff
state active
no shutdown
exit

vlan 103
name Admin
state active
no shutdown
exit

vlan 104
name Guest
state active
no shutdown
exit

interface Vlan 100
description Managment
no shutdown
exit

interface Vlan 101
description Student
no shutdown
exit

interface Vlan 102
description Staff
no shutdown
exit

interface Vlan 103
description Admin
no shutdown
exit

interface Vlan 104
description Guest
no shutdown
exit

interface gig0/1
description WT-Wired
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1,100-104
switchport trunk native vlan 1
exit

interface gig0/2
description WT-Wireless
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 100-104
switchport trunk native vlan 100
exit

interface gig0/3
description AP1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 100-104
switchport trunk native vlan 100
exit

interface gig0/4
description AP2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 100-104
switchport trunk native vlan 100
exit

exit
write memory



To confirm VLAN configuration is correct, type SHOW VLAN, you see something like this, if not, your VLANS are not configured correctly.


Switch#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    g0/1, g0/2, g0/3, g0/4

                                                g0/5, g0/6, g0/7, g0/8

                                                g0/9, g0/10, g0/11, g0/12

                                                g0/13, g0/14, g0/15, g0/16

                                                g0/17, g0/18, g0/19, g0/20

                                                g0/21, g0/22, g0/23, g0/24

                                                g0/25, g0/26, g0/27, g0/28

                                                g0/29, g0/30, g0/31, g0/32

                                                g0/33, g0/34, g0/35, g0/36

                                                g0/37, g0/38, g0/39, g0/40

                                                g0/41, g0/42, g0/43, g0/44

                                                g0/45, g0/46, g0/47, g0/48

                                                g0/49, g0/50

100  Managment                        active

101  Student                            active

102  Staff                                active

103  Admin                              active

104  Guest                              active

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                   act/unsup

1005 trnet-default                     act/unsup


For Switch 2, both ports involved would have the same configuration as port 0/2 on Switch 1.  For Switch 3, port 0/1 would be the same as Switch 1 port 0/2, and Switch 3 port 0/23 & 0/24 would be the same as Switch 1 port 0/1.

A helpful hint to help keep your port configuration information straight is to not only save each switch's configuration in a spreadsheet, but also print that spreadsheet and keep it in the wiring closet with each switch.  Many people use 8 1/2" x 11" sheet protectors designed to hold a piece of paper in a binder, and hang them right from the rack...one per switch.  This is especially useful with bigger networks that use larger switches with >100 ports on them, each with a potentially different configuration.

Details
Last Modified: 11 Years Ago
Last Modified By: sburns
Type: HOWTO
Rated 5 stars based on 1 vote
Article has been viewed 9.8K times.
Review Date: -
Options
Also In This Category